CanaDream v 2.7 for ATS


CanaDream v 2.7 for ATS

Coast to Coast map 2.6 minimum is REQUIRED for playing or game crash

Priority:
1-CanaDream 2.7
2-Coast to Coast 2.6

2.7
compatible ATS 1.32
compatible C2C 2.6
add .sui system files for more compatibility with other mods

Credits
ManiaX
1 Star2 Stars3 Stars4 Stars5 Stars (No Ratings Yet)
Loading...

This content was uploaded by website visitors. If you notice any mistake, please let us know.

What is this mod use for

American truck simulator is not as challenging as before? Familiar surrounding and tasks are not interesting anymore? It can be fixed easily - Best American Truck Simulator Mods are exactly what you need. Install these mods to update your favorite game! You will be able to choose new trucks, routes and challenge yourself constantly. Are you ready for the challenging features of Best ATS mods? Start right now and be the first to beat all the opponents!



You may also like...

1 Response

  1. Ralloh says:

    Why does the same old shit keep getting posted. This is 2.7. I already have 2.7.1. What the hell?

Leave a Reply

Your email address will not be published. Required fields are marked *