CanaDream v 2.5 Mod

CanaDream v 2.5 Mod

Coast 2 Coast 2.4 minimum is REQUIRED for playing or game crash

1-CanaDream 2.5
2-Coast 2 Coast 2.4

* compatible ATS 1.30
* compatible C2C 2.4


What is this mod use for

American truck simulator is not as challenging as before? Familiar surrounding and tasks are not interesting anymore? It can be fixed easily - American Truck Simulator Mods are exactly what you need. Install these mods to update your favorite game! You will be able to choose new trucks, routes and challenge yourself constantly. Are you ready for the challenging features of ATS mods? Start right now and be the first to beat all the opponents!

Leave a Reply

Your email address will not be published. Required fields are marked *